Составьте программу , которая формирует массив из 10 целых чисел значения которых лежат в интервале от - 10 до 10 ( [ 10: 10] ) . программа должна выводить на экран исходный массив затем преобразовать элементы массива , увеличивая в два раза положительные элементы , а для отрицательных элементы менять знак на противоположный . выведите на экран преобразованный массив . в паскале !
const n=10;
var a:array[1..n] of integer;
i: integer;
begin
for i:=1 to n do
begin
a[i]:=random(21)-10;
write (a[i]:3,' ');
if a[i]>0 then a[i]:=a[i]*2;
if a[i]<0 then a[i]:=-a[i]
end;
writeln;
for i:=1 to n do write (a[i]:3,' ')
end.