В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Zhenek195643
Zhenek195643
04.02.2021 11:57 •  Информатика

Составьте программу для решения следующей . введите с клавиатуры два числа: n и m. если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран. если первое число положительное, а второе отрицательное, то уменьшите их в два раза и выведите результаты. иначе, найдите и выведите среднее арифметическое этих чисел.

Показать ответ
Ответ:
DavtynGalia
DavtynGalia
07.07.2020 12:34
Program asd;
uses crt;
var n,m,min:integer;
 r:real;
begin 
Write('Введите число  n: '); 
Readln(n); 
Write('Введите число  m: '); 
Readln(m);
 If n>m then
min:=m 
else
min:=n;  
 If (n>100) and (m>100) then 
begin   
 n:=min; 
 m:=min; 
   Writeln('n= ',n,' m= ',m); 
end;
   If (n>0) and (m<0) then 
 Writeln('n= ',n/2,' m= ',m/2)   
 else   
  r:=(n+m)/2; 
    Writeln('Среднее арифм. :  ',r); 
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота