В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составьте программу для решения одной из следующих , которая запрашивает значение элементов одномерного числового массива а и подсчета суммы элементов массива, меньших своего номера.

Показать ответ
Ответ:
rufdiana
rufdiana
03.10.2020 17:29
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=5;

Var
 a:array[1..n] of integer;
 i,s:integer;
begin
 for i:=1 to n do
  begin
   readln(a[i]);
   if a[i]<i then s:=s+a[i];
  end;
 writeln(s);
end.

Пример ввода:
2
2
1
1
2
Пример вывода:
4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота