В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу в паскале которая вставит между буквами введенного слова пробел

Показать ответ
Ответ:
DFleX
DFleX
11.06.2020 20:14

var
    s, s_new: string;
    i: integer;

begin
    read(s);
    for i := 1 to length(s) do
        s_new := s_new + s[i] + ' ';
    writeln(s_new);
end.

0,0(0 оценок)
Ответ:
polonnikovdanil
polonnikovdanil
11.06.2020 20:14

 Program BlankWord;

Uses Crt;

var s1:string;

        l:integer;

begin

     clrscr;

     write('Введите Слово:');

     readln(s1);

     l=length(s1);

 

     for i:=l downto 1 do
         if(i mod 2 = 0)then
              Insert(' ', s1, i);
              writeln(s1);
              readkey;

     

 end.

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота