В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
5ксюША88881
5ксюША88881
07.06.2022 08:00 •  Информатика

Составьте программу. Дано натуральное число n. Выведите на экран все числа кратные трём.

Показать ответ
Ответ:
лиза1585
лиза1585
02.09.2022 19:57
{ввожу текст, затем слово. Переменная flag нужна для того, чтобы в нее записать 1, если из слова встретиться в тексте хотя бы раз буква. Если это случилось, то Flag становится равной 1. К буквам слова и текста обращаемся как к массиву a[i] b[j]}
var
a,b:string;
i,n,k,j,flag:integer;
begin
flag:=0;
   writeln('Введите текст');
   readln(a);
   Writeln('Введите слово');
   Readln(b);
k:=length(a);
n:=length(b);
   for i:=1 to n do
       for j:=1 to k do
           if a[i]=b[j]then
               flag:=1;
if flag=1 then
   writeln('Y')
else
   writeln('N');
end.
   
0,0(0 оценок)
Ответ:
Маргарита2021
Маргарита2021
20.05.2021 19:12
Private Sub CommandButton1_Click()
    Dim s() As Integer, n As Integer, m As Integer
    Dim i As Integer, j As Integer
    Dim min As Integer, max As Integer, q As Integer, w As Integer
    Cells.Clear
    n = InputBox("CTROKI", , 4)
    m = InputBox("CTOLBEC", , 5)
    Randomize
    ReDim s(n, m) As Integer
    For i = 1 To n
        max = -100: min = 100
        For j = 1 To m
            s(i, j) = Int(Rnd() * 60 - 10)
            Cells(i, j) = s(i, j)
            Cells(i + 2 + n, j) = s(i, j)
            If min > s(i, j) Then
                min = s(i, j)
                q = j
            End If
            If max < s(i, j) Then
                max = s(i, j)
                w = j
            End If
        Next j
        Cells(i + 2 + n, w) = min
        Cells(i + 2 + n, q) = max
    Next i
End Sub
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота