В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
helissieble
helissieble
15.01.2023 06:49 •  Информатика

Составить программу выводящую двумерный массив, элементами которого являются 0, а на главной диагонали стоят 2. (pascal)
решите !

Показать ответ
Ответ:
Gosha22228888
Gosha22228888
02.10.2021 16:20

pascal. код в объяснении

Объяснение:

program mass;

const n = 6; //размер массива

var a: array[0..n, 0..n] of integer;

   i, j: integer;

begin

   for i := 0 to n do

     begin

     for j := 0 to n do

       begin

         a[i, i] := 2;

         Write(a[i, j]:4);  

       end;

       WriteLn;

     end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота