В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
daria003ss2
daria003ss2
20.09.2022 20:25 •  Информатика

Составить программу вычисления значений функции y на отрезке [-1;8] с шагом 3. y = - cos2x

Показать ответ
Ответ:
qwertzasd
qwertzasd
31.12.2020 15:37
// PascalABC.NET 3.0, сборка 1073
const
  nn=30;
  mm=30;
var
  a:array[1..mm,1..nn] of integer;
  m,n,i,j,k,s:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(m,n);
  Randomize;
  Writeln('*** Исходный массив ***');
  k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if Odd(a[i,j]) then Inc(k)
    end;
    Writeln
  end;
  if k>5 then begin
    Writeln('Средние арифметические отрицательных элементов по строкам');
    for i:=1 to m do begin
      s:=0; k:=0;
      for j:=1 to n do
        if a[i,j]<0 then begin Inc(k); s:=s+a[i,j] end;
      if k>0 then Writeln(s/k:9:5) else Writeln('  0.00000');
    end
  end
  else begin
    Writeln('*** Результирующий массив ***');
    for i:=1 to m do begin
      for j:=1 to n do begin a[i,j]:=2*a[i,j]; Write(a[i,j]:4) end;
    Writeln
    end
  end
end.

Тестовые решения:
Введите число строк и столбцов массива:
8 6
*** Исходный массив ***
 -16  -8  -1  24 -22   1
  -9 -20 -25  13 -11  10
 -15  10 -12  20 -22   3
  -6  25  -3  25 -14  22
  24  -4  24  17  -4 -17
 -23  -9 -22   1 -18 -13
 -12  13   6 -16   2 -13
  19   8 -22  14  -3   4
Средние арифметические отрицательных элементов по строкам
-11.75000
-16.25000
-16.33333
 -7.66667
 -8.33333
-17.00000
-13.66667
-12.50000

Введите число строк и столбцов массива:
3 5
*** Исходный массив ***
   3  24 -21 -22  -8
 -21  14 -22   0 -22
  15 -16  -2   6  22
*** Результирующий массив ***
   6  48 -42 -44 -16
 -42  28 -44   0 -44
  30 -32  -4  12  44
0,0(0 оценок)
Ответ:
Зара7878
Зара7878
20.06.2020 13:50

Складіть програму мовою С++ для знаходження функції y(x), де x Є [a, b] з кроком h. Дані для y(x), a, b, h вказані в таблиці.

y = x + sin(3x);

[a, b], h   [-1, 3], h = 0.3

Програма:

С++:

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   float y, a, b, h;

   cout << "a = ";  cin >> a;

   cout << "b = ";  cin >> b;

   cout << "h = ";  cin >> h;

   while (a <= b) {

       y = a + sin(3 * a);

       cout << "y = " << y << " при x = " << a << endl;

       a += h;

   }

}

Результат:

a = -1

b = 3

h = 0.3

-1.14112 при x = -1

-1.56321 при x = -0.7

-1.33204 при x = -0.4

-0.39552 при x = -0.1

0.764643 при x = 0.2

1.4975 при x = 0.5

1.47546 при x = 0.8

0.942254 при x = 1.1

0.528424 при x = 1.4

0.774186 при x = 1.7

1.72058 при x = 2

2.87844 при x = 2.3

3.59854 при x = 2.6

3.56297 при x = 2.9

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота