В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Лера089
Лера089
06.01.2022 13:05 •  Информатика

Составить программу вычисления выражения: max(x^2+y^3, y^2+z^3)-4

Показать ответ
Ответ:
диана2340
диана2340
10.09.2020 07:19
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (x,y,z):=ReadReal3('Введите x,y,z:');
  Writeln(Max(x*x+y*y*y,y*y+z*z*z)-4)
end.

Пример
Введите x,y,z: 2.6 -1.05 4
61.1025
0,0(0 оценок)
Ответ:
Matroyshka
Matroyshka
10.09.2020 07:19
If (x+2*y) > (y*3*z-4*x) then max := (x+2*y) else max := (y*3*z-4*x);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота