В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
оарташ
оарташ
30.05.2021 09:49 •  Информатика

Составить программу вычеслений степени числа а с натуральным показателем n.

Показать ответ
Ответ:
алибек29
алибек29
26.05.2020 06:58

Тут используется собственная функция для нахождения степени числа.

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int powerFunction(int, int);

int main()
{
   int number, power;

   cout << "Enter A: ";
   cin >> number;
   cout << "Enter N: ";
   cin >> power;

   cout << number << " to the power of " << power
      << " = " << powerFunction(number, power) << endl;

   return 0;
}

int powerFunction(int n, int p)
{
   int temp = 1;

   for(int i = 0; i < p; i++)
   {
      temp *= n;
   }

   return temp;
}


Составить программу вычеслений степени числа а с натуральным показателем n.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота