В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ankur1
Ankur1
06.04.2022 09:17 •  Информатика

ПО ИНФОРМАТИКЕ!ОЧЕНЬ Составить программу, которая напечатает таблицу перевода расстояний из дюймов в сантиметры для значений от 1 до 10 дюймов с шагом 0,5 дюйма. Формула перевода: 1дюйм = 2,54 см.

Показать ответ
Ответ:
qnorri
qnorri
29.04.2022 13:59

Program pr;

uses crt;

Var a, b, c,x1,x2,x3:integer;

Begin

Writeln('Введите a, b, c');

readln(a, b, c);

if (a<=b) and (b<=c) then

        Begin

              a:=a*a*a;

              b:=b*b*b;

              c:=c*c*c;
              Writeln(a);
              Writeln(b);
              Writeln(c);

        end;

if (a>b) and (b>c) then

Begin

a:=a*(-1);

b:=b*(-1);

c:=c*(-1);
Writeln(a);
Writeln(b);
Writeln(c);
end

 

 

 

else

if (a<b) and (a<c) then Begin b:=a; c:=a; Writeln(a); Writeln(b); Writeln(c); end;

if (b<a) and (b<c) then Begin a:=b; c:=b; Writeln(a); Writeln(b); Writeln(c); end;

if (c<a) and (c<b) then Begin a:=c; b:=c; Writeln(a); Writeln(b); Writeln(c); end;

readln;
end.

0,0(0 оценок)
Ответ:
коаладоби
коаладоби
23.10.2021 19:48

Lazarus-та жоба жасау екі кезеңнен тұрады: жобаның сыртқы пішінін жасау және программалық кодын жазудан тұрады. Жобаның интерфейсін жасауға жоба пішінінің терезесі мен программа кодын жазу редакторын өзара тығыз байланыста қолданамыз. Жоба пішінінің терезесіне жаңа компоненттерді енгізсек, программа кодының құрылымыда автоматты түрде өзгереді. Алғашқы жобаны дайындауды бастайық.

Жоба дайындау төмендегі кезеңдерден тұрады:

1. Пуск – Программы – Lazarus командасын орындап, программа ерезесін ашамыз.

Lazarus терезесі ашылғанда терезеде жоғарыда айтылған мәзір, компонент платформасы, объекттер инспекторы, жоба пішіні терезесі мен программа коды редакторының терезесі пайда болады.

2. Тінтуір арқылы мәзірдегі «Файл=>Создать форму» команда-сын таңдасақ, программа терезесінде «Жоба пішіні» және «Бастапқы код редакторының» терезесі пайда болады (5.5, 5.6-суреттер).

3. «Объекттер инспекторы (Инспектор объектов) => Қасиет (Свойства) => Caption (тақырып)» командаларын таңдап, оған «Жоба пішіні» деп жазып, жобаның тақырыбын өзгертеміз (5.8-сурет).

5.8-сурет. Жоба пішінінің тақырыбын өзгерту

4. «Жоба пішініне» батырма қосу үшін компонент платформасынан «Button1» батырмасын таңдаймыз (5.9-сурет).

5.9-сурет. Пішінге «Button1» батырмасын енгізу

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота