В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kopil199420p017kl
kopil199420p017kl
02.03.2020 16:13 •  Информатика

Составить программу, содержащую ветвления и определяющую, принадлежит ли точка с координатами(x,y) заштрихованной области

Показать ответ
Ответ:
Zhuldyzovazarina
Zhuldyzovazarina
04.12.2021 16:58

Python

from random import randint

n=int(input('Введите количество элементов массива : '))

if n%2!=0:

 n=n+1

a=[0]*n

for i in range (0, n):

 a[i]=randint(1,100)

 

print(a)

i=0

k=0

# сортируем первую часть массива по возрастанию

while i< n//2-1:

 if a[i]>a[i+1]:

     k=a[i]

     a[i]=a[i+1]

     a[i+1]=k

     i=-1

 i +=1

# сортируем вторую часть массива по убыванию

while i < n-1:

 if a[i]<a[i+1]:

     k=a[i]

     a[i]=a[i+1]

     a[i+1]=k

     i=n//2-1

 i +=1

 

print(a)  


массив содержит чёткое количество элементов напишите программу которая сортирует первую половину мас
0,0(0 оценок)
Ответ:
хомяк2005
хомяк2005
17.04.2022 01:56

Объяснение:

1) Разницу находил по модулю, если нужна просто разность убери abs в третьей строчке с конца.

var n,cou,x,mn,n1,n2,n3,n4:integer;

begin

 readln (x);

 n4:=x mod 10;

 x:=x div 10;

 n3:=x mod 10;

 x:=x div 10;

 n2:=x mod 10;

 x:=x div 10;

 n1:=x mod 10;

 writeln (abs(n2-n3));

 writeln (n4/n1);

 end.

2) var n,cou,x,mn,n1,n2,n3,h,m,s,x1,x2,x3,x4:integer;

begin

 write ('Сколько сейчас на часах (Вводи Часы Минуты секунды): ');

 readln (h,M,s);

 writeln ('Сколько времени пройдет: ');

 readln (n1,n2,n3);

 H:=h*3600;

 M:=M*60;

 s:=H+M+s;

 n1:=n1*3600;

 n2:=n2*60;

 n3:=n3+n2+n1;

 x1:=s+n3;

 x2:=x1 div 3600;

 x3:=(x1-x2*3600) div 60;

 x4:=(x1-x2*3600-x3*60);

 writeln ('Будет часов: ',x2, ' Будет минут: ',x3, ' Будет секунд: ',x4);

 end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота