В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dashashirobokova
dashashirobokova
18.04.2021 06:48 •  Информатика

Составить программу, резервирующую массив из 100 элементов для хранения целых чисел, заполняет его случайными числами (процедура random) и выводит на экран среднее арифметическое значение элементов массива. В программе выделить процедуру заполнения (назовем ее CreateRandomArray) и функцию вычисления среднего арифметического значения массива (пусть это будет MediaArray). Передача данных в процедуры выполняется по ссылке , очень сильно нужно.

Показать ответ
Ответ:
shikunovnikitkp00sz1
shikunovnikitkp00sz1
15.02.2022 15:04

#include <iostream>

#include <cstdlib>

#include <ctime>  

using namespace std;  

int main()

{

setlocale(LC_ALL, "rus");  

int randomDigit = 0;

int version = 0;  

srand(time(NULL));

randomDigit = 1 + rand() % 7;  

cout << "Отгадайте число, которое я загадал (1-7):";

cin >> version;  

if (version == randomDigit)

{

 cout << "Дa! Я загадал число - " << randomDigit << endl;

}

else

{

 cout << "Нет! Я загадал число - " << randomDigit << endl;

}  

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота