В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
oksanka199800
oksanka199800
16.11.2020 07:20 •  Информатика

Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10, если таких элементов нет, вывести "no". в паскале.

Показать ответ
Ответ:
Ликааааааааап
Ликааааааааап
20.06.2020 05:54
Const n=15;
var
a: array [1..n] of integer;
i:integer;
p:boolean;
begin
  p:=true;
  for i:= 1 to n do
  begin
    write('Введите A[',i,']: ');
    readln(a[i]);
  end;
  i:=1;
  while p and (i<n) do
  begin
    if a[i]+a[i+1]>10 then
      begin
        p:=false;
        writeln;
        writeln('(A[',i,']=',a[i],') + ((A[',i+1,']=',a[i+1],') > 10');
      end;
    inc(i);
  end;
  writeln;
  if p then writeln('NO');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота