В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составить программу на языке Составить программу нахождения минимального элемента и его номера в массиве вещественных чисел не более 40, задаваемых вводом с клавиатуры.
2. Сформировать массив (вывести на экран) из т случайных целых чисел на промежутке от -60 до 60, найти сумму чисел больших 20.

Показать ответ
Ответ:
khydyrov1404
khydyrov1404
06.01.2022 08:57
Var
  x,y:integer;
  vcp,dx,dy:real;
begin
  Write('Возраст Тани='); Read(x);
  Write('Возраст Мити='); Read(y);
  vcp:=(x+y)/2;
  dx:=x-vcp; dy:=y-vcp;
  Writeln('Средний возраст равен ',vcp);
  if dx>0 then begin
    Writeln('Таня старше среднего возраста на ',dx,' лет,');
    Writeln('а Митя младше среднего возраста на ',-dy,' лет.')
  end
  else
    if dx=0 then Writeln('Таня и Митя ровесники')
    else begin
      Writeln('Таня младше среднего возраста на ',-dx,' лет,');
      Writeln('а Митя старше среднего возраста на ',dy,' лет.')
    end
end.

Тестовое решение:
Возраст Тани=15
Возраст Мити=12
Средний возраст равен 13.5
Таня старше среднего возраста на 1.5 лет,
а Митя младше среднего возраста на 1.5 лет.
0,0(0 оценок)
Ответ:
Deafandblind
Deafandblind
06.10.2021 17:05
Наверное, можно и своими словами объяснить. Ну ты сам(а) логический порассуждай чем различие и сходство между древним и современным компьютеров. Ну например, У современных компьютеров мощный процессор, болшая память, множество программ, игр, и все это в одном небольшом системном блоке. Это очень компактно!
А у старых компьютеров память еле-еле достигали 1 гб. А так же скорость, ну это просто ужас.Компьютер оперировал 72 числами, состоящими из 23 десятичных разрядов, затрачивая по 3 секунды на операции сложения и вычитания. Умножение выполнялось в течение 6 секунд, деление — 15,3 секунды, на операции вычисления логарифмов и выполнение тригонометрических функций требовалось больше минуты.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота