В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
shakutis
shakutis
16.08.2022 04:46 •  Информатика

Составить программу на языке С++, решающую следующую задачу: Дано трехзначное число.
Найти сумму и произведение его цифр.

Показать ответ
Ответ:
mamka18
mamka18
28.08.2020 16:35

#include <iostream>

int main()

{

int N, s1 = 0, s2 = 1;

setlocale(LC_ALL, "Russian");  // Русский язык в консоли

std::cin >> N;

while (N > 0)

{

 s1 += N % 10;

 s2 *= N % 10;

 N /= 10;

}

std::cout << "Сумма: " << s1 << std::endl;

std::cout << "Произведение: " << s2;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота