В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Mozg1237384
Mozg1237384
28.12.2022 08:30 •  Информатика

Составить программу на языке программирования visual c++! два автомобиля движутся по кольцевой дороге длины l в противоположных направлениях. они начинают движение из одной точки и едут с постоянными скоростями v1 и v2 соответственно. требуется определить, на каком расстоянии друг от друга они окажутся в момент времени t. на вход 4 натуральных числа l, v1, v2, t, разделенных пробелом. все числа не превосходят 100. выведите расстояние между автомобилями в момент времени t – длину кратчайшей из двух дуг дороги между автомобилями.

Показать ответ
Ответ:
рттири
рттири
30.09.2020 19:17

#include<iostream>
using namespace std;
int main(){
  int l,v1,v2,t;
  cin>>l>>v1>>v2>>t;
  int x1 = (t * v1)%l,x2 = (-t*v2)%l;
  if(x1<0) x1=l-x1;
  if(x2<0) x2=l+x2;
  cout<<min(abs(x1-x2),abs(l-x1-x2));
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота