В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
arnautovvladik
arnautovvladik
05.02.2021 11:06 •  Информатика

составить программу на языке программирования паскаль для подсчета ненулевых элементов среди 100 вводимых случайным образом в диапазоне от -100 до +100

Показать ответ
Ответ:
2005282
2005282
10.02.2020 14:45

#include

float f(float x, float a, float b, float c)

{

float result;

+ 10)< 0) & & (b ! = 0))

{

  result = a*x*x + c*x + b;

}

else

{

  + 10) > 0) & & (b ==0))

  {

  result = (x - a) / (x - c);

  }

  else

  {

  result = -x/a - c;

  }

}

return result;

}

int main(void)

{

float

x_start = -100,

x_end = 100,

dx = 2,

a = 3,

b = 2,

c = 5;

printf("x\t\t\tf(x)\n");

for(float i = x_start; i < x_end; i += dx)

{

  printf("%f\t%f\n", i, f(i, a, b, c));

}

return 0;

}

0,0(0 оценок)
Ответ:
лана278
лана278
09.04.2022 18:42

ответ:

а) какую величину на руси измеряли ведрами?

ведром в древней руси измеряли объем.

основная дометрическая мера объема жидкостей – ведро = 1/40 бочки = 10 кружек = 30 фунтов воды = 20 водочных бутылок (0,6) = 16 винных бутылок (0,75) = 100 чарок = 200 шкаликов = 12 литров.

деление на более мелкие меры проводилось по двоичному принципу: ведро делили на 2 полуведра или на 4 четверти ведра или на 8 получетвертей, а также на кружки и чарки.

б) что измеряют галлонами? баррелями? в каких странах используются эти единицы измерения?

баррель — это старинная единица измерения объёма жидкости.

американский нефтяно́й ба́ррель — единица измерения объёма нефти, равная 42 галлонам, или 158,988 л. интересно, что баррель для измерения прочих жидкостей в америке вмещает только 31,5 галлона.

галло́н — мера объёма, обычно используется для жидкостей, в редких случаях — для твёрдых тел.

американский галлон и галлон различаются: американский галлон = 3,785 литра; галлон = 4,546 литра.

баррель (около 159 л) и галлон (около 4 л), как меры объема в основном используют в и сша.

в) на емкостях иностранного производства иногда встречается такое обозначение объема: 100cl (100 сантилитров). выразите этот объем на принятых в россии единицах.

1 сантилитр равно 0.01 литр

1 литр равно 100 сантилитр

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота