Пришлось перезадать во У меня проблемы с информатикой, программируем на паскале. задали два задания, впал в ступор. буду очень благодарен если будут объяснения решения. на языке паскаля, 8 кл Решить задачи с цикла FOR.
№2. Найти минимальное из введенных трёхзначных чисел. Программа получает на вход сначала количество чисел, затем сами числа (не большие 1000). Программа выводит на экран одно число: наименьшее число из введённых. (подсказка: переменной min присвоить значение 1000)
№3. Вывести на экран таблицу умножения на А. Пользователь вводит число А, программа выводит на экран произведение числа А на все числа от 1 до 10 в виде
5*1 = 5
5*2=10…
var
i, n, count2, max2, count3, min3 : Integer;
begin
ReadLn(n);
count2:=0; max2:=0;
count3:=0; min3:=1000;
for i:=1 to n do
begin
Read(n);
if (n>9) and (n<100) then
begin
inc(count2);
if n>max2 then max2:=n;
end;
if (n>99) and (n<1000) then
begin
inc(count3);
if n<min3 then min3:=n;
end;
end;
if count2=count3 then
WriteLn(0)
else if count2>count3 then
WriteLn(max2)
else
WriteLn(min3);
end.
Объяснение: