В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
LeklA
LeklA
22.12.2020 21:53 •  Информатика

Составить программу на языке паскаля: даны числа a,b,c. составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:
равносторонний,равнобедренный или какой либо другой.

Показать ответ
Ответ:
lilyabelousova
lilyabelousova
24.05.2020 13:09

var a,b,c: integer;

begin

  readln(a,b,c);

  if (a>b+c) or (b>a+c) or (c>a+b) then begin writeln('Треугольник не сущесвует'); exit; end;

  if (a=b) or (b=c) or (a=c) then writeln('Равнобедренный треугольник');

  if (a=b) and (b=c) and (a=c) then writeln('Равносторонний треугольник');

  if (sqr(c)=sqr(a)+sqr(b)) or (sqr(b)=sqr(c)+sqr(a)) or (sqr(a)=sqr(b)+sqr(c)) then writeln('Прямоугольный треугольник');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота