В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
xDVadiKSlivE
xDVadiKSlivE
16.03.2022 12:26 •  Информатика

Составьте программу для вычисления суммы чисел кратных 8 вдиапазоне от а до b. java

Показать ответ
Ответ:
knopendui
knopendui
08.10.2020 01:06
Import java.util.Scanner;

class Strange
{
    public static void main (String[] args)
    {
        Scanner sc = new Scanner(System.in);
        int a = sc.nextInt();
        int b = sc.nextInt();
        sc.close();
        int r = a % 8;
        if (r != 0) a += 8 - r;
        int s = 0;
        for (int i=a; i <= b; i+=8) s += i;
        System.out.println("Сумма:" + s);
    }
}

Составьте программу для вычисления суммы чисел кратных 8 вдиапазоне от а до b. java
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота