В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
voprooos
voprooos
06.03.2021 02:32 •  Информатика

составить программу на Python Разработать программу, которая для двумерного вещественного массива S*T выводит на экран элементы, значения которых находятся вне диапазона от
-V до V (V задается) , а произведение их индексов делится без остатка на другое задаваемое число В

Показать ответ
Ответ:
edshabashenko
edshabashenko
18.05.2021 03:22
Найти цифры числа можно двумя
1. Если число короткое можно пользоваться div и mod, т.е. например, 1-я цифра 3-значного числа - это целое от деления на 100, третья цифра - остаток от деления на 10, чтобы найти вторую цифру надо сначала взять целое от деления на 10 и потом остаток от деления этого целого на 10.
2. Если число длинное или его длина неизвестна, то лучше преобразовать его в строку, найти длину строки и брать по одному символу с соответствующим индексом.

Блок-схема первого варианта на фото
Дано 3 значное число.найдите среднее арифметическое и его цифры. блок схема
0,0(0 оценок)
Ответ:
potochnystanis
potochnystanis
30.04.2021 07:05
begin
  var n:=readInteger('Число элементов массива-');
  var a:=ArrRandom(n,-50,50); a.Println;
  for var i:=1 to n-2 do a[i]:=2*(i+1);
  a.Println
end.

Пример
Число элементов массива- 10
-40 4 -49 0 -47 41 49 33 -31 -1
-40 4 6 8 10 12 14 16 18 -1

begin
  var n:=readInteger('Число элементов массива-');
  var a:=ArrRandom(n,-50,50); a.Println;
  var i1:=a.IndexMax;
  var i2:=a.IndexMin;
  Writeln(a[min(i1,i2)+1:max(i1,i2)].Where(x->x<0).Sum)
end.

Пример
Число элементов массива- 18
-45 -30 -49 -44 34 -5 -12 -28 22 14 -39 -20 -46 50 6 21 20 -47
-194

begin
  var a:=ReadlnString('Введите строку;').ToCharArray;
  // было сделано так только ради получения массива символов,
  // который на самом деле только мешает
  Writeln(a);
  if Pos('...',a.JoinIntoString)>0 then
    Writeln('Троеточие в массиве есть')
  else Writeln('Троеточия в массиве нет')
end.

Пример
Введите строку; 6ye$% DFDRT..drrtert...DFDGD
[6,y,e,$,%, ,D,F,D,R,T,.,.,d,r,r,t,e,r,t,.,.,.,D,F,D,G,D]
Троеточие в массиве есть
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота