В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
marinafox253
marinafox253
03.01.2023 05:18 •  Информатика

Составить программу на паскале находящюю самое длинное слово в строке начинающееся на букву а , и выводящуюю количество букв в

Показать ответ
Ответ:
филя24
филя24
24.05.2020 10:46

var s:string;
i,n,max:byte;

begin
n:=0;i:=1;max:=0;
write('Введите s -> ');readln(s);

while i<=length(s) do begin
if (i=1) or (s[i]=' ') then begin
if i <> 1 then inc(i);
if (i<=length(s))and((s[i]='a') or (s[i]='A')) then

while i<=length(s) do
if s[i]<>' ' then begin
inc(n);
inc(i);
end else break;
end;
inc(i);

if max<n then max:=n;
n:=0;
end;
write('Длина самаго длинного слова на букву A = ',max);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота