В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ксю11111111147
Ксю11111111147
01.10.2020 18:37 •  Информатика

Составить программу на C++ для решения следующей задачи. Дан массив А, состоящий из 10 действительных чисел. Обменять местами минимальный и последний элемент массива. Массив заполнить с клавиатуры и вывести на экран.

Показать ответ
Ответ:
JuLIaNNa2747
JuLIaNNa2747
15.10.2020 15:05

#include <iostream>

#include <vector>

using namespace std;

void swap(int *a, int *b){

   int temp = *a;

   *a = *b;

   *b = temp;

}

signed main() {

   const int n = 10;

   vector<int> a(n);

   int mx = -INT_MAX, mn = INT_MAX, i = 0, j = 0;

   for(int k = 0; k < n; k++){

       cin >> a[k];

       if(a[k] > mx){mx = a[k]; i = k;}

       if(a[k] < mn){mn = a[k], j = k;}

   }

   swap(a[i],a[j]);

   for(auto &i:a)

       cout << i << " ";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота