В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AlinaAlina2672
AlinaAlina2672
23.05.2022 07:27 •  Информатика

Составить программу: Массив из 15 элементов заполнить целыми случайными числами в диапазоне от 0 до 20.
Найти:
А) Количество нечетных элементов массива
Б) Сумму элементов массива кратных 3 или 5 и их количество
В) Сумму отрицательных элементов массива располагающихся на четных позициях
Написать комментарии к каждому оператору

Показать ответ
Ответ:
alesaastudinap0dbun
alesaastudinap0dbun
26.09.2022 08:08

print("Ноль в качестве знака операции"

     "\nзавершит работу программы")

while True:

   s = input("Знак (+,-,*,/): ")

   if s == '0':

       break

   if s in ('+', '-', '*', '/'):

       x = float(input("x="))

       y = float(input("y="))

       if s == '+':

           print("%.2f" % (x+y))

       elif s == '-':

           print("%.2f" % (x-y))

       elif s == '*':

           print("%.2f" % (x*y))

       elif s == '/':

           if y != 0:

               print("%.2f" % (x/y))

           else:

               print("Деление на ноль!")

   else:

       print("Неверный знак операции!")

0,0(0 оценок)
Ответ:
Насонка
Насонка
08.01.2021 04:11
Процесс постепенного превращения переднеазиатской клинописи в слоговое письмо нашел свое завершение в древнеперсидской (ахеменидской) клинописи.Ко времени образования персидской державы Ахеменидов (VI в. до н.э.) в Передней Азии были широко распространены две принципиально различные системы письма — логографически-слоговая вавилонская клинопись и чисто фонетическое консонантно-звуковое арамейское письмо, возникшее на основе финикийского алфавита.М. Коэн, отвечая на вопрос о том, чем было вызвано создание персами своей особой системы клинописи при широком распространении в Персии арамейского письма, считает возможным две гипотезы. «Можно предположить, — пишет он, — развитие (персидской клинописи) из местного письма, которое нам неизвестно и которое сделалось слоговым эволюционным путем. Легенда говорит о герое-цивилизаторе царе Тахмурате (имя, обозначающее большую лисицу), который отнял у демонов письмо, украденное ими у добрых гениев и укрытое ими. Другая легенда говорит о письме семи форм, которое включало 365 знаков. Может быть, наоборот, древнеперсидское письмо — это опыт без вокализация алфавита, заимствованного у арамейцев и переодетого в другую форму; в последнем случае это было бы примером вторичного силлабизма».Нам представляется более правдоподобной иная гипотеза. Если у персов до образования ими династии Ахеменидов существовала бы какая-то своя система письма, из которой позднее развилась персидская слоговая клинопись, то при использовании столь долговечного письменного материала, как глина, до нас дошли бы какие-либо памятники этого гипотетического письма. Поскольку же такие памятники совершенно неизвестны, более правдоподобным является отнесение начала персидской клинописи ко времени ахеменидской династии.Навряд ли можно считать персидскую слоговую клинопись и простой «вокализацией алфавита, заимствованного у арамейцев». Как показано далее, в следующем разделе этой главы, во всех слоговых системах письма, возникших на консонантно-звуковой основе, для обозначения слогов с одинаковыми согласными звуками обычно применялись знаки, включавшие одинаковые или сходные графические элементы. В персидской клинописи знаки, служившие для обозначения таких слогов, наоборот, как правило, не имеют каких-либо общих, объединяющих их графических признаков.Поэтому персидскую клинопись, видимо, следует считать системой письма, промежуточной между охарактеризованными в начале данной главы слоговыми системами первой и второй группы, искусственным построением, исходящим в основном из ассиро-вавилонской клинописи, но с последовательным применением фонетического принципа письма.Принцип этот, обеспечивающий наиболее точную передачу речи, был известен персам на примере арамейского письма. Однако консонантное арамейское письмо, обозначавшее лишь согласные звуки и пропускавшее гласные, было удобным только для семитских и хамитских языков, в которых корневая основа слова строится преимущественно из согласных звуков; наоборот, для индоевропейского персидского языка, в котором гласные звуки играли большую роль, участвуя, наряду с согласными, в построении основ слов, консонантное арамейское письмо было неудобным. Кроме того, персы считали себя как бы наследниками былого могущества завоеванной ими вавилонской державы; учитывали они и международный характер ассиро-вавилонской клинописи.Поэтому при построении своей государственной системы письма персы переняли у вавилонян клинообразную форму знаков; заимствовали они у вавилонян также и слоговой принцип, позволявший (в отличие от арамейского консонантного письма) более или менее точно передавать не только согласные, но и гласные звуки древнеперсидского языка. В то же время под арамейским влиянием персы почти полностью исключили из своего письма логограммы, превратив его в последовательно фонетическую слого-звуковую систему, причем с обозначением не только слогов, но и неслоговых согласных звуков.Древнеперсидский алфавит состоит из трех знаков для изолированных гласных (a, i, и) и 33 слоговых знаков (согласная + гласная a, i или и). Логограмм в персидском письме применялось только четыре — «страна», «земля», «царь» и «бог».Трудность обозначения смежных и конечных согласных звуков преодолевалась в персидской клинописи следующим образом. Каждый слоговой знак персидского письма, наряду с основным, слоговым значением (согласная + гласная), мог применяться также и для передачи согласного звука; так, например, знак мог обозначать и слог ba и согласную b. Это придавало персидскому письму многозначность (полифоничность), но в то же время облегчало передачу смежных и конечных согласных звуков.Таким образом, по типу письма, по значению знаков древнеперсидское письмо представляло собой своеобразную слого-звуковую систему, а по графике, по форме знаков являлось одной из разновидностей клинописи.Древнеперсидская клинопись была создана, по утверждению большинства ученых, во второй половине VI в. до н.э
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота