Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
228dflbr
03.08.2020 01:15 •
Информатика
Составить программу которая выбросит из записи числа n все цифры равные 1, оставив при этом прежним порядок остальных цифр. пример 5101234-50234
Показать ответ
Ответ:
bomicbomic
03.10.2020 06:41
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
var s:=ReadlnString.Where(x->x in ['0'..'9']);
var r:=s.Where(x->x<>'1').Println('');
end.
Тестовые примеры:
5101234
50234
3,1415926535897932384626433832795028 - первые знаки числа ПИ
345926535897932384626433832795028
98765432111111111110000111111000001111111123456789
9876543200000000023456789
0,0
(0 оценок)
Ответ:
lehmannastyaaovt8b2
03.10.2020 06:41
#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int li;#define mp make_pair
#define F first
#define S second
#define sqr(a) ( (a) * (a) )
#define pb push_back
#define INF 999999999
#define ret(a) cout << endl; system("pause"); return(a)
//#define ret(a) return(a)using namespace std;int main()
{
string s, ans;
cin >> s;
for(int i = 0 ; i < s.size() ; i ++)
if( s[i] != '1' )
ans.pb( s[i] );
cout << ans;
ret(0);
}
0,0
(0 оценок)
Популярные вопросы: Информатика
kravchenjatkop00zs0
27.10.2021 23:57
Дано: = 21(10), = 23(8). Какое из чисел, записанных в двоичной системе, отвечает условию b c a? 1) 100002) 100013) 110004) 10100...
оксана754
05.07.2020 16:28
Які блоки, як правило, містять подійно-орієнтовані програми? Блок опрацювання цієї подіїБлок відповідностей подіямБлок отримання повідомлення про подіюБлок переробки цієї подіїБлок...
TennisDiyar
29.10.2020 18:45
Даны координаты точек:(6;12)(4;11)(1;12)(4;13)(6;12)(8;13)(11;12)(8;11)(6;12)(7;10)(6;7)(5;10)(6;12)(5;14)(6;17)(7;14)(6;12)(10;8)(9;5)(13;12)(14;8)(13;10)(9;5)(8;2) Отметь точки...
mrscom
29.01.2023 22:47
Алина записала IP-адрес на листке бумаги и положила его в карман куртки. Алинина мама случайно постирала куртку вместе с запиской. После стирки Алина обнаружила в кармане три...
Alice5u811
29.01.2023 12:57
1. Какая форма организации действий называется циклом? 2. Дайте определение алгоритма циклической структуры. 3. Какие другие названия у циклического алгоритма? 4. Какая команда...
danik2012daniweufyv3
29.08.2021 07:04
Перевидите 13мб в байты 128мб в гигабайты 0,12мб в биты 0,02гб в килобайты 99112бит в килобайты...
eroly12ramblerr2
09.12.2022 07:34
Решить : пользователь вводит 4 числа, найти максимальное и минимальное из этих чисел , 24 !...
nastiabl5ct
25.04.2022 07:26
1) Что подразумевает понятие «информационная культура человека»? умение программировать знание курса информатики умение использовать информационные технологии понимание закономерностей...
whitesnaff
10.06.2020 15:06
В каком из условных операторов допущена ошибка?Oif (a b) and (b 0) then c:=a+b;O if a b then min:=a; else min:=b;Oif b=0 then writeln( Деление невозможно прямо сейчас...
PolinaCartonova
04.02.2022 00:08
Составить программу нахождения произведения чисел от m до...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
var s:=ReadlnString.Where(x->x in ['0'..'9']);
var r:=s.Where(x->x<>'1').Println('');
end.
Тестовые примеры:
5101234
50234
3,1415926535897932384626433832795028 - первые знаки числа ПИ
345926535897932384626433832795028
98765432111111111110000111111000001111111123456789
9876543200000000023456789
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int li;#define mp make_pair
#define F first
#define S second
#define sqr(a) ( (a) * (a) )
#define pb push_back
#define INF 999999999
#define ret(a) cout << endl; system("pause"); return(a)
//#define ret(a) return(a)using namespace std;int main()
{
string s, ans;
cin >> s;
for(int i = 0 ; i < s.size() ; i ++)
if( s[i] != '1' )
ans.pb( s[i] );
cout << ans;
ret(0);
}