В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Germionochka
Germionochka
02.06.2021 17:31 •  Информатика

Составить программу которая r раз находит m! значение r,m заполняются генератор случайных чисел с аргументом 6

Показать ответ
Ответ:
ssshhhhhhannnnssha
ssshhhhhhannnnssha
08.06.2020 00:22

Объяснение:

function factorial(n:integer):integer;

var

 i, p:integer;

begin

 p:=1;

 for i:=1 to n do

   p:=p*i;

 factorial:=p;

end;

var

 r, m:integer;

 k:integer;

begin

 randomize;

 r:=random(6);

 writeln('r = ', r);

 for k:=1 to r do begin

   m:=random(6);

   writeln(m, '! = ', factorial(m));

 end;

 readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота