В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
cocscocsovich3
cocscocsovich3
02.03.2023 10:19 •  Информатика

Составить программу,формирующую произвольный массив(с функции random) из 40 элементов. все элементы,большие 50,заменить на -6

Показать ответ
Ответ:
Дарья20099
Дарья20099
04.08.2020 13:23
Const Sz = 40; 
var   a: array [1..Sz] of integer; 
N: integer;  
i: integer; 
k:integer; 

begin
k:=50; 
N := 40; 

for i:=1 to N do   
a[i] := Random(100); 
writeln('Элементы массива: '); 

for i:=1 to N do    write(a[i],' ');   
writeln();   

begin 
for i:=1 to n do begin 
if a[i] > N then 
a[i] := -6 end;
writeln('Заменяем элементы > 50 на -6: '); 

for i:=1 to N do   
write(a[i],' ');   
writeln(); 
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота