В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mira23141
mira23141
15.02.2020 13:16 •  Информатика

Составить программу для вычисления величины s по формуле: s=2(σ^20[i=1]*cos(b^2[i])+e^^10[k=1]*z[k]) program p5_4; var p,s,s1: real; i,k: integer; b: array[1..20] of integer; z: array[1..10] of integer; begin writeln(' z: '); for k: =1 to 10 do begin z[k]: =random(11)-5; write(z[k]: 4); end; writeln; writeln(' b: '); for i: =1 to 20 do begin b[i]: =random(11)-5; write(b[i]: 4); end; p: =1; s1: =0; for i: =1 to 20 do s1: =2*(s1+cos(sqr(; for k: =1 to 10 do p: =p*(z[k]); s: =s1+p; writeln(' s=',s: 2: 5); end. нам преподаватель сказал сделать без команды random, а я не пойму как она здесь будет выглядеть без random, так же и другая

Показать ответ
Ответ:
wiwhha
wiwhha
31.07.2020 07:29
Без рандома:

program p5_4;
var
P,S,S1:real; i,k:integer;
b:array[1..20] of integer;
z:array[1..10] of integer;
begin
writeln(' z: ');
for k:=1 to 10 do
begin
Readln(z[k]);
write(z[k]:4);
end;
writeln;
writeln(' b: ');
for i:=1 to 20 do
begin
Readln(b[i]);
write(b[i]:4);
end;
P:=1;
S1:=0;
for i:=1 to 20 do
S1:=2*(S1+cos(sqr(b[i])));
for k:=1 to 10 do
P:=P*(z[k]);
S:=S1+P;
writeln(' S=',S:2:5);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота