В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alinahan444
alinahan444
01.04.2020 09:40 •  Информатика

Составить программу для решения задачи: сколько моль и сколько молекул любого вещества содержится в одном грамме этого вещества.

Показать ответ
Ответ:

Программа:

{Free Pascal Compiler version 3.0.4+dfsg-23 [2019/11/25] for x86_64}

{Copyright (c) 1993-2017 by Florian Klaempfl and others}

{Target OS: Linux for x86-64}

program test;

const

 start = -100;

 finish = 50;

 count = 100;

var

 X : array of integer; {массив}

 i : integer; {Счётчик цикла}

 S : integer; {Сумма положительных}

begin

Randomize;

SetLength(X, count+1);

{Генерация массива из 100 элементов от -50 до 50}

for i := 1 to count do

 X[i] := Round( Random * start) + finish;

{Вывод сгенерированного массива на экран}

for i := 1 to count do

 write(X[i]:4);

writeln; writeln;

{Подсчёт положительных элементов}

S := 0;

for i := 1 to count do

 if (x[i] > 0) then

  S := S + x[i];

 

writeln('Сумма положительных S = ', S);

end.


Найти сумму тех элементов массива, которые имеют положительные значения(для Паскаль)​
0,0(0 оценок)
Ответ:
vika78678
vika78678
19.05.2022 01:46

Ғаламтордың пайдасы

Ғаламтор - ғылым мен техниканың шынайы жетістігі. Ол - сөзсіз. Интернетті қолдана алатын кез келген адам өзіне қалаған ақпарат мен мағлұматты тауып, қажетіне жарата алады. Мазалап жүрген сауалдарының жауабын табады. Әлемдік жаңалықтар мен оқиғалардан хабардар болып отыруға көмектеспек. Бұл жағынан интернет адамның білімі мен қабілетін, тұлғалық қасиеттерін дамытуға ықпал етеді.

Ғаламтордың зиянды жақтары

Өкінішке орай, жоғарыда айтылған ғаламтордың артықшылықтарына қарамастан, оның зиян жақтары да көп болып шықты. Ғаламторға деген тәуелділік қазір ғаламдық мәселеге айналып бара жатыр. Соның кесірінен адамдар арасындағы күнделікті байланыс бұзылып барады. Адамдар бір-бірімен сөйлесуді, әңгімелесуді, сырын бөлісуді ұмытып бара жатқандай. Жылы шырай танытып, шүлдірлеп сөйлесуден, жанды, табиғи қатынастан қалып барамыз.

Ғаламтордың келесі зиянды тұсы - адамның денсаулығы. Компьютер алдында ұзақ отырған адамның денсаулығы да нашарлай түседі. Өйткені ол қозғалыстан қалып, оның соңы бел, арқа, көз ауруларына әкелуі мүмкін.

Одан бөлек, қазіргі таңда ғаламторда алаяқтар да көбейді. Олардан сақтанудың да қамын жасаған абзал.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота