В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Сложное123
Сложное123
01.01.2021 19:55 •  Информатика

Составить программу:

а) Вычисления сумму кубов натуральных чисел до тех пор, пока сумма кубов очередного числа не превысит 1000.

б) Вычисления значение функции Y=X2, при х= 8; 6; 4; 2.

Показать ответ
Ответ:
lolagrigoreva
lolagrigoreva
23.11.2021 19:05

26

Объяснение:

a = 23 (дано число a)

выполняем цикл (увеличиваем число a на 5 и проверяем условие число a больше 35, если условие истинно (да) выходим из цикла, если ложное (нет), то повторяем цикл)

a = a + 5 = 23 + 5 = 28

a > 35 (28 > 35, нет)

a = a + 5 = 28 + 5 = 33

a > 35 (33 > 35, нет)

a = a + 5 = 33 + 5 = 38

a > 35 (38 > 35, да)

a = a * 2 =  38 * 2 = 76 (увеличиваем число a в 2 раза)

проверяем условие является ли число a двузначным, если условие истинно (да), то выполняем левую ветку, а правую ветку (ещё один цикл) не трогаем (если условие ложно (нет), то выполняем правую ветку (ещё один цикл), а левую ветку не трогаем)

9 < a < 100 (9 < 76 < 100, да - двузначное)

a = a - 50 = 76 - 50 = 26 (уменьшаем число a на 50)

получаем ответ (больше ничего не делаем)

0,0(0 оценок)
Ответ:
iprin
iprin
13.08.2021 19:57
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота