В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vladisimus
Vladisimus
06.01.2020 05:53 •  Информатика

Написать программу на языке Паскаль для вычисления наибольшего общего делителя двух целых положительных чисел по готовой блок-схеме


Написать программу на языке Паскаль для вычисления наибольшего общего делителя двух целых положитель

Показать ответ
Ответ:
Настя097343
Настя097343
15.01.2022 16:17

ответ: вес текстового файла с брошюрой 38.328125 Кбайт

ДАНО:

брошюра на 16 страниц,

в среднем каждая страница содержит 32 строки,

каждая строка содержит 64 символа,

а каждый символ весит 1 байт

вычисляем кол-во символов

16 * 32 = 10 * 32 + 6 * 32 = 320 + 192 = 512(с) - кол-во строк

512 * 64 = 512 * 60 + 512 * 4 = 37200 + 2048 = 39248(с) - кол-во символов

вычисляем кол-во Кбайт

39248 * 1 = 39248(б) - вес в байтах

39248 / 1024 = 38.328125(кб) - вес в килобайтах(да признаюсь тут уже использовал калькулятор)

Объяснение:

0,0(0 оценок)
Ответ:
LoliTyan1
LoliTyan1
20.12.2022 11:21

ответ:1 2 3 4 5 6 7 8 9 11 12 15 22 24 33 36 44 48 55 66 77 88 99 111 112 115 122 124 126 128 132 135 144 155 162 168 175 184 212 216 222 224 244 248 264 288 312 315 324 333 336 366 384 396 412 424 432 444 448 488 515 555 612 624 636 648 666 672 728 735 777 784 816 824 848 864 888 936 999

Объяснение:var i,j:Integer;

begin

i:=1;

while i<1000 do begin

j:=i;

while j>0 do begin

if (j mod 10=0) then j:=-1 else if (i mod (j mod 10)>0) then j:=-1;

if j>0 then j:=j div 10;

end;

if j=0 then write(i,' ');

inc(i);

end;

end.

Не более трёх граней, не значит три грани, поэтому думаю что так должно быть! )

Результат:

1 2 3 4 5 6 7 8 9 11 12 15 22 24 33 36 44 48 55 66 77 88 99 111 112 115 122 124 126 128 132 135 144 155 162 168 175 184 212 216 222 224 244 248 264 288 312 315 324 333 336 366 384 396 412 424 432 444 448 488 515 555 612 624 636 648 666 672 728 735 777 784 816 824 848 864 888 936 999

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота