В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
famin19810
famin19810
06.03.2021 14:57 •  Информатика

Сорочно программу которая в последовательности целых чисел определяет кол-во кратных 5 или 7 . программа получает на вход целые числ кол-во введеных чисел неизвестно последовальность чисел заканчивается число 0 ( 0 признак окончания ввода не входит в последовательность) ко-во чисел не превышает 1000 введеные числа по модулу не превышает 30 000 программа должна вывести оно число кол-во чисел кратных 5 или 7 пример работы - 22 25 -14 0 выходные данные 2

Показать ответ
Ответ:
MashaMalycheva
MashaMalycheva
03.07.2020 17:02
Using System;

namespace ConsoleApp {
    internal class Program {
        private static void Main() {
            var number = 0;
            int n;
            do {
                Console.WriteLine("Введите число");
                n = Convert.ToInt32(Console.ReadLine());
                if (n != 0 && (n % 5 == 0 || n % 7 == 0)) {
                    number++;
                }
            } while (n != 0);

            Console.WriteLine("Кол-во = " + number);

            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота