Соотнесите пример программы, написанной Для машины "Поста", с результатом, к которому он может привести 1)1 - 2 2 v 1 2)1-2 2 ! 3)1 — 1 Результативная Остановка Безрезультатная Остановка Безостановочная работа машины
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017 // Внимание! Если программа не работает, обновите версию!
begin var s:=ReadlnString; var c:=s.ToWords.Where(t->t.Length>1).SelectMany(w->w.Pairwise) .Select(t->t[0]+t[1]).GroupBy(t->t).Select(t->(t.Key,t.Count)) .OrderByDescending(t->t[1]).ThenByDescending(t->t[0]).First[0]; Writeln('Чаще других встречается цепочка "',c,'"') end.
Пример TWAS BRILLIG AND THE SLITHY TOVES DID GYRE AND GIMBLE IN THE WABE ALL MIMSY WERE THE BOROGOVES AND THE MOME RATHS OUTGRABE Чаще других встречается цепочка "TH"
Замечание: ограничение на длину строки увеличено до 2 млн. символов.
var m: array[1..N, 1..N] of integer; i, j: integer; rec: record mmax: integer = -(maxint); ind: record i: integer; j: integer; end; end;
begin for i := 1 to N do for j := 1 to N do begin read(m[i, j]); if abs(m[i, j]) > rec.mmax then begin rec.mmax := abs(m[i, j]); rec.ind.i := i; rec.ind.j := j; end; end; writeln('Максимальный по модулю элемент матрицы ', rec.mmax, '(', rec.ind.i, ';', rec.ind.j, ')'); end.
Пример: Входные данные: 1 2 3 4 5 -9 7 8 6 Выходные данные: Максимальный по модулю элемент матрицы 9(2;3)
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
var c:=s.ToWords.Where(t->t.Length>1).SelectMany(w->w.Pairwise)
.Select(t->t[0]+t[1]).GroupBy(t->t).Select(t->(t.Key,t.Count))
.OrderByDescending(t->t[1]).ThenByDescending(t->t[0]).First[0];
Writeln('Чаще других встречается цепочка "',c,'"')
end.
Пример
TWAS BRILLIG AND THE SLITHY TOVES DID GYRE AND GIMBLE IN THE WABE ALL MIMSY WERE THE BOROGOVES AND THE MOME RATHS OUTGRABE
Чаще других встречается цепочка "TH"
Замечание: ограничение на длину строки увеличено до 2 млн. символов.
const
N = 5;//Размерность массива
var
m: array[1..N] of integer;
begin
var pr := 1;
for var i := 1 to N do
begin
read(m[i]);
if m[i] <> 0 then pr := pr * m[i];
end;
writeln(pr);
end.
Пример:
Входные данные:
1 2 3 0 5
Выходные данные:
30
2)
const
N = 3;//Размерность матрицы
var
m: array[1..N, 1..N] of integer;
i, j: integer;
rec: record
mmax: integer = -(maxint);
ind: record
i: integer;
j: integer;
end;
end;
begin
for i := 1 to N do
for j := 1 to N do
begin
read(m[i, j]);
if abs(m[i, j]) > rec.mmax then begin
rec.mmax := abs(m[i, j]);
rec.ind.i := i;
rec.ind.j := j;
end;
end;
writeln('Максимальный по модулю элемент матрицы ', rec.mmax, '(', rec.ind.i, ';', rec.ind.j, ')');
end.
Пример:
Входные данные:
1 2 3
4 5 -9
7 8 6
Выходные данные:
Максимальный по модулю элемент матрицы 9(2;3)