Сколько существует значений s, подаваемых на вход программе, при которых в результате работы программы на экран будет выведено значение 125? var n, s: integer; begin n :=1; readln(s); while s > n do begin s :=s - 15; n := n * 5 end; write(n) end.
Во первых вычислим сколько битов имеет рукопись автора для этого 16•64•1024•2048=147483648 битов. нам известно что в одном байте 8 битов. из этого следует 147483648:8=131072 байта. в мегабайте 1000000 байтов. из этого 131072:1000000=0,131072 мегабайта рукописи. а еще нам известно что рукопись имеет 2650 иллюстраций по 6 мегабайткаждая.из этого выходит 2650•6=15900 мегабайт для того чтобы узнать сколько ушло памяти нафлешке 15900+0,131072= 15900,131072≈15900,1311 в одном гиге 1000 мегабайт 15900,1311:1000= 15,9001311 гигабайт. в общем флеш карта заполнена этой рукописью
1. var s:string; m1,m2,m3:integer; begin writeln('- Привет! Я компьютер, а как тебя зовут?'); write('- '); readln(s); writeln('- ',s,', введи свои оценки по 3 предметам'); write('- '); readln(m1,m2,m3); writeln('- ',s,', твой средний ', (m1+m2+m3)/3); end.
Пример: - Привет! Я компьютер, а как тебя зовут? - Алёна - Алёна, введи свои оценки по 3 предметам - 4 4 4 - Алёна, твой средний 4
2. var a,b:integer; begin write('a = '); readln(a); b:=(a div 100)*100 + (a mod 10)*10 + (a div 10 mod 10); writeln('b = ',b); end.
для того чтобы узнать сколько ушло памяти нафлешке 15900+0,131072= 15900,131072≈15900,1311
в одном гиге 1000 мегабайт
15900,1311:1000= 15,9001311 гигабайт. в общем флеш карта заполнена этой рукописью
var s:string; m1,m2,m3:integer;
begin
writeln('- Привет! Я компьютер, а как тебя зовут?');
write('- '); readln(s);
writeln('- ',s,', введи свои оценки по 3 предметам');
write('- '); readln(m1,m2,m3);
writeln('- ',s,', твой средний ', (m1+m2+m3)/3);
end.
Пример:
- Привет! Я компьютер, а как тебя зовут?
- Алёна
- Алёна, введи свои оценки по 3 предметам
- 4 4 4
- Алёна, твой средний 4
2.
var a,b:integer;
begin
write('a = '); readln(a);
b:=(a div 100)*100 + (a mod 10)*10 + (a div 10 mod 10);
writeln('b = ',b);
end.
Пример:
a = 123
b = 132