В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lololka125
lololka125
25.12.2021 19:02 •  Информатика

Склавиатуры вводится символ. составить программу позволяющую буквой латиницы или кириллицы является этот символ

Показать ответ
Ответ:
sab1na666
sab1na666
17.08.2021 16:58

Здесь А - массив, N - количество чисел в массиве, sum - сумма элементов массива, count - количество искомых элементов, sum * 1.0 / N - это и есть среднее арифметическое, причем если здесь не умножать на 1.0, то результат будет округлен и программа будет уже работать неправильно, а если умножать, то все хорошо, потому что sum * 1.0 / N становится вещественным числом

Объяснение:

Здесь можно использовать динамику(чтобы не занимать место в памяти статическим массивом):

#include <iostream>

using namespace std;

int main()

{

int N, sum=0, count=0;

cin >> N;

int* A = new int[N];

for (int i = 0; i < N; i++) {

 cin >> A[i];

 sum += A[i];

}

for (int i = 0; i < N; i++) if (A[i] < (sum * 1.0 / N)) count++;

cout << count;

       delete[] A;

}

Но если динамика еще не изучена, то:

#include <iostream>

using namespace std;

int main()

{

int N, sum=0, count=0, A[1000];

cin >> N;

for (int i = 0; i < N; i++) {

 cin >> A[i];

 sum += A[i];

}

for (int i = 0; i < N; i++) if (A[i] < (sum * 1.0 / N)) count++;

cout << count;

}

0,0(0 оценок)
Ответ:
nurkenalmazbek
nurkenalmazbek
17.07.2021 11:06
Var a1, b1, c1, a2, b2, c2, p1, p2, s1, s2: real;
begin
  writeln('Введите строны первого треугольника: ');
  read(a1, b1, c1);
  writeln('Введите стороны второго треугольника: ');
  read(a2, b2, c2);
  p1 := (a1 + b1 + c1) / 2;
  p2 := (a2 + b2 + c2) / 2;
  s1 := sqrt(p1 * (p1 - a1) * (p1 - b1) * (p1 - c1));
  s2 := sqrt(p2 * (p2 - a2) * (p2 - b2) * (p2 - c2));
  if (s1 + 1e-3 > s2) and (s1 < s2 + 1e-3) then writeln('Равновеликие')
                                           else writeln('Неравновеликие');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота