В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
135670ш8ге5
135670ш8ге5
30.11.2022 09:00 •  Информатика

Решите , используя язык программирования паскаль: напишите программу вычисления стоимости покупки, состоящей из нескольких карандашей, линеек и тетрадей. их количество и цену задать вводом. ответ вывести в виде: сумма к оплате: … руб … коп.

Показать ответ
Ответ:
NikaSempay
NikaSempay
03.10.2020 02:35
Var
k,kc,ks, r,rc,rs, l,lc,ls: Integer;
Summa: Integer;
begin
WriteLn('Введите цену карандаша'); ReadLn(kc);
WriteLn('Введите цену ручки'); ReadLn(rc);
WriteLn('Введите цену линейки'); ReadLn(lc);

WriteLn('Введите кол-во карандашей'); ReadLn(k);
WriteLn('Введите кол-во ручек'); ReadLn(r);
WriteLn('Введите кол-во линеек'); ReadLn(l);

ks:= k * kc; // цена карандашей
rs:= r * rc; // цена ручек
ls:= l * lc; // цена линеек
Summa:= ks + rs +ls; // общая цена всех 3-х
WriteLn('Сумма = ', Summa;
ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота