В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
зайка583
зайка583
29.01.2023 15:23 •  Информатика

Решить в паскале с использованием цикла с ! составить программу запроса пароля пока не будет введён пароль верно. в программе предусмотреть счётчик неправильных вводов пароля.

Показать ответ
Ответ:
hrustam2004
hrustam2004
25.05.2020 21:57

var

 parole, s: string;

 Count: byte;

begin

 parole := 'Земля прощай. В добрый путь!';

 Count := 0;

 

 repeat

   Writeln('Введите пароль');

   Readln(s);

   Count += 1

 until (s = parole) or (Count = 3);

 

 if Count = 3 then

 begin

   Write('Вы не индентификацию. Доступ закрыт');

   Halt

 end

 else

   Write('Доступ разрешен.')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота