В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MaksSeemo
MaksSeemo
24.05.2023 18:53 •  Информатика

Решить в pascal abcдан целочисленный массив из 10 элементов. элементы массива могут принимать целые значения от 0 до 100 – учащихся выпускного класса, полученные на экзамене по информатике. напишите программу, которая позволяет найти и вывести количество учащихся, чьи на экзамене выше среднего по классу.2. дан целочисленный массив из 10 элементов. если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная – количество чётных. например, для массива из 6 элементов, равных соответственно 2, 6, 12, 17, 3, 8, ответом будет 2 – количество нечётных элементов, так как общая сумма всех элементов чётна. 3. дан целочисленный массив из 10 элементов. элементы массива могут принимать целые значения от 0 до 100 включительно. напишите программу, которая находит и выводит количество пар элементов массива, сумма которых не кратна 6, а произведение меньше 1000. под парой подразумевается два подряд идущих элемента массива.

Показать ответ
Ответ:
staseem35
staseem35
08.12.2021 01:43

Напишу основные идеи на языке Си,но преобразовать несложно Вам будет.

 

1.  int N,c1,c2,razn,chastn;

     scanf ("%d",&N); // запрашиваем двузначное число

     

    c1=N%10;
     N/=10;

     c2=N%10;  

      razn=c2-c1;  chastn=c2/c1;

2. int Z;

     

     if (Z>0)  Z=Z+1;

     if (Z==0) Z=10;

3. int  Z, c_right, c_left;

      

     c_right=Z%10;

      Z=Z/10;    

     c_left=Z%10;

4. int Z;

     if  ( Z%2==0 ) четное ;

     else нечетное ;

5. int a,b,sum ; //имеем ввиду a<b

 

     do

        { a=a+1;

           sum=sum+a;

         }

        while (a!=b-1); //  (a!=b) - если от а до Б включительно

 

Как то так. Если возникнут вопросы- пишите :)

 

      

       

0,0(0 оценок)
Ответ:
Аккаунт удален
Аккаунт удален
23.07.2020 14:50

ответ: Программа выполняет рандом массива

Объяснение:

const N = 10; //Переменная которая содержит число 10

var //переменная для массива

arr: array[1..N,1..N] of integer; //массив

max: integer;  

i,j: byte;// переменные

begin //конец цикла

randomize; //рандом

for i:=1 to N do begin //цикл  

for j:=1 to N do begin //цикл

arr[i,j] := random(1000); // рандом всего массива по циклу  

write(' |',arr[i,j]:3,'| '); //вывод текста

end;//конец  

writeln; //переброс на следующую строку

end;//конец

for i:=1 to N do //цикл

write(' '); //вывод строки

writeln; //переброс на следующую строку

for j:=1 to N do begin //цикл

max := arr[1,j]; // запись цикла

for i:=2 to N do //цикл

if arr[i,j] > max then //проверка если массив больше максимального  

max := arr[i,j]; // запись массива

write(' ',max:3,' '); //вывод результата

end; //конец

writeln; //переброс на следующую строку

end." //конец кода

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота