В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
qweasdzxcrfvtgbmn
qweasdzxcrfvtgbmn
07.04.2023 12:11 •  Информатика

Ребята Напишите программу в питоне 'чат-бот'.Бот должен:иметь 4 функции.Например Музика,Игры,Фильм и т.к на каждую категорию должен быть код.В проекте лолжны бвть функции:int,print,input,while,for и другие​

Показать ответ
Ответ:
gsergey1
gsergey1
17.01.2021 21:06

print("Привет! Я недавно появился в интернете! Я могу рассказать тебе про музыку/игры/кино/книги")

fest = input("Ты хочешь посмотреть мои функции? ")

if fest.lower() == 'да':

   print("Круто!")

   print("Введи 1, если хочешь узнать об играх")

   print("Введи 2, если хочешь узнать о книгах")

   print("Введи 3, если хочешь узнать о музыке")

   print("Введи 4, если хочешь узнать о кино")

   x = int(input("Ввод: "))

   if x == 1:

       print("Круто! В играх можно классно провести время с друзьями!")

   elif x == 2:

       print("Книги - наше всё, без книг мы будем никем!")

   elif x == 3:

       print("Музыка, в наше время музыка очень популярна, послушай хотя бы альбом Деда Мороза!")

   elif x == 4:

       print("Ух, люблю кино. Боевики, милодраммы, не хочешь сходить как-нибудь? ;)")

   print("Отлично, как бы ты оценил меня? Оцени по трём критериям: интерес, веселье, польза")

   for i in range(3):

       x = int(input("Введи оценку (от 1 до 10) "))

   v = int(input(" за оценку, напоследок вычисли мне значение выражения:" (2 * 2)+2))

   while v != 6:

       print("Неверно, попробуй еще")

       v = int(input())

   print(" тебе, пока!")

   

else:

   print("Жаль, ну тогда пока :(")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота