В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Юсик1854
Юсик1854
02.06.2020 09:20 •  Информатика

Рассмотрите программу. Напишите, что делает данная программа. Перепишите данную программу с циклом For (Python)

пэжэ​


Рассмотрите программу. Напишите, что делает данная программа. Перепишите данную программу с циклом F

Показать ответ
Ответ:
Shkola17032004
Shkola17032004
09.03.2021 07:20

Что делает:

Программа получает на вход кол-во итераций введённых с клавиатуры.

В каждой итерации программа запрашивает число и проверяет на чётность(или кратность 2). Если запрашиваемое число кратное двум, то к счётчику count прибавляет единицу и проходим дальше по итерациям.

В конце программа выводит кол-во чисел кратных двум.

цикл for:

count = 0

for i in range(int(input())):

   if int(input()) % 2 == 0:

       count +=1

print(count)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота