В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
anuta00002000
anuta00002000
25.07.2020 03:20 •  Информатика

PYTHON
Делители числа
Напишите программу, которая отображает все делители числа N.
Входные данные: вводится единственное натуральное число n.
Выходные данные: на одной строке вывести все делители данного числа. Используйте для вывода параметр
end = " " с командой print(). Пример: print(x, end = " ").
Пример 1
Ввод:
12
Вывод:
1 2 3 4 6 12
В пайтоне

Показать ответ
Ответ:
айлан8
айлан8
14.10.2020 07:23

a = int(input("Введи число: "))

for i in range(1,a+1):

   if a%i == 0:

       print(i,end = " ")


PYTHONДелители числа Напишите программу, которая отображает все делители числа N. Входные данные: вв
PYTHONДелители числа Напишите программу, которая отображает все делители числа N. Входные данные: вв
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота