В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ZheniaBabich
ZheniaBabich
06.02.2021 02:58 •  Информатика

Python Создайте класс Student с параметрами:
int id;

String name;

String surname;

double gpa;

Обязательно создайте конструктор.

Создайте функцию getStudentData();

Данный метод возвращает все данные студента.

В классе Main, вы должны создать 5 объектов разных студентов с разными параметрами.

Создайте массив из класса Student, заполните массив 5 объектами класса Student которые мы создали до этого, и используя цикл, выведите данные по каждому студенту.

Показать ответ
Ответ:
kitmyfaded
kitmyfaded
04.06.2020 11:38

program fdjh;

uses crt;

var

 F:text;

 in_name, z:string;

 max,n,i,d:integer;

begin

 writeln('Введiть iм`я файлу');

 read(in_name);

 

 assign(F,in_name);

 rewrite(F);

 

 writeln('Введiть розмiр файлу');

 read(n);

 

 for i:=1 to n do

 begin

   d:=random(101)-25;

   z := inttostr(d);

   write(F,z+#13#10);

 end;

 close(F);

 

 reset(F);

 max := -25;

 while not eof(F) do

 begin

   readln(F,z);

   d := StrToINt(z);

   if (d > max) and (d mod 4 = 0) then

     max:=d;    

 end;

 

 if max = -25 then writeln('Максимальний кратний 4 в файлі не існує')

 else writeln('Максимальний кратний 4 = ',max);

 

 close(F);

end.

0,0(0 оценок)
Ответ:
ArturSSexe
ArturSSexe
26.05.2023 02:55

===== PascalABC.NET =====

begin

 var a := ReadlnInteger('Введите целое число:');

 try

   Println(1 div a);

 except

   on System.DivideByZeroException do

     Println('Попытка деления на ноль');

 end;

 try

   var s := ReadlnString('Введите число с дробной частью:');

   s.ToReal.Println;

 except

   on System.FormatException do

     Println('Неверная запись вещественного числа')

 end;

 var b := ArrRandom(5, -10, 10);

 try

   Println(b[ReadlnInteger('Какой элемент массива вывести?')])

 except

   on System.IndexOutOfRangeException do

     Println('Неверный индекс')

 end;    

 try

   BigInteger.Parse(ReadlnString('Введите число:')).ToString.ToInteger

 except

   on System.OverflowException do

     Println('Слишком большое число')

 end

end.

Примечание: StackOverflowException невозможно перехватить в версии .NET выше 2.0.


Написать программу, в которой при каких-то (придумать самим) действиях пользователя будут возникать
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота