составить программу в Паскале
Ресторан закупает ежедневно Z1 кг масла по 188,50 р/кг, Z2 кг
сметаны по 95 р/кг, Z3 кг сливок по 104,50 р/кг. Цена товара
определяется командой присваивания, количество – командой ввода.
Программа должна определить суммы, необходимые для покупки
отдельных товаров и общую сумму.
var
sum, a, b, c: real;
begin
Write('Введите количество масла в кг.: ');
Read(a);
Write('Введите количество сметаны в кг.: ');
Read(b);
Write('Введите количество сливок в кг.: ');
Read(c);
sum := a * 188.5;
Writeln('За ', a, 'кг. масла, получится: ', sum, 'р.');
sum := b * 95;
Writeln('За ', b, 'кг. сметаны, получится: ', sum, 'р.');
sum := c * 104.5;
Writeln('За ', c, 'кг. сливок, получится: ', sum, 'р.');
Writeln('Общая сумма: ', (a * 188.5) + (b * 95) + (104.5), 'р.');
end.
Тестовое решение:
Введите количество масла в кг.: 6
Введите количество сметаны в кг.: 4
Введите количество сливок в кг.: 2
За 6кг. масла, получится: 1131р.
За 4кг. сметаны, получится: 380р.
За 2кг. сливок, получится: 209р.
Общая сумма: 1615.5р.