(Python) Бандиты Гарри и Ларри отдыхали на природе. Решив пострелять, они выставили на бревно несколько банок из-под кока-колы (не больше 10). Гарри начал банки по порядку, начиная с самой левой, Ларри — с самой правой. В какой-то момент получилось так, что они одновременно одну и ту же последнюю банку.
Гарри возмутился и сказал, что Ларри должен ему кучу денег за то, что тот лишил его удовольствия несколько банок. В ответ Ларри сказал, что Гарри должен ему еще больше денег по тем же причинам. Они стали спорить кто кому сколько должен, но никто из них не помнил сколько банок было в начале, а искать банки по всей округе было неохота. Каждый из них помнил только, сколько банок он сам.
Определите по этим данным, сколько банок не Гарри и сколько банок не Ларри.
Входные данные:
Пользователь вводит 2 числа (каждое меньше 10) — количество банок Гарри и Ларри соответственно.
Выходные данные:
Выведите 2 числа — количество банок, не Гарри и Ларри соответственно.
Машинная память работает по принципу 0 и 1, т. е. 0 это нету сигнала, 1 это есть сигнал. По этому для понимания мы может просто записывать это в таблицу.
К примеру возьмём 2 клетки. Если и первая клетка и вторая равна 1, тогда выполняется что то одно, если не равны, то что то другое.
На самом компьютере да и вообще любом современном электронном устройстве всё работает по этому же принципу, только вместо таблицы с 0 и 1, используется "Есть питания" или же "Нету питания", поступил ток по нужному проводу или нет.
1)var
a:array[1..5]of integer;
i,n,s:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
writeln('Введите число');
s:=0;
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then s:=s+a[i]
end;
writeln('Сумма положительных элементов массива равна ', s)
end.
2)var
a:array[1..10]of integer;
i,n,P:integer;
begin
writeln('Введите число элементов');
readln(n);
writeln('Введите число');
P:=1;
for i:=1 to n do begin
read(a[i]);
if a[i] mod 6 = 0
then P:=P*a[i]
end;
writeln('Произведение элементов массива кратных 6 равна ',P)
end.
3)var
a:array[1..5]of integer;
n,i:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
writeln('Введите число');
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then begin
a[i]:=a[i]*3;
writeln('Новый элемент равен: ',a[i])
end;
if a[i]<=0 then begin
a[i]:=a[i]+5;
writeln('Новый элемент равен: ',a[i])
end;
end;
end.
Буду рад если отметишь мой ответ как лучший