Напишите программу, в которой вводится число. Требуется вывести его так, что бы составляющие его цифры шли в обратном порядке. Например, вводится число 4096, надо вывести 6904. (Примичание: используйте условие внутри тела цикла, mod и div)
На вход: 123 7354
На выход 321 4537
2. P=a+b, S=1/2*a*b, где a и b - данные катеты
3. Пусть даны координаты трех вершин треугольника A(x1;y1), B(x2;y2), C(x3;y3).
Расстояние между двумя точками вычисляется по формуле
Тогда периметр треугольника можно вычислить по формуле:
P=sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2).
Площадь треугольника по формуле Герона вычисляется по формуле:
, где -полу периметр треугольника.
S=sqrt((sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x2-x1)^2+(y2-y1)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-+sqrt((x3-x2)^2+(y3-y2)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x3-x1)^2+(y3-y1)^2))
4. Среднее геометрическое трех чисел вычисляется по формуле
или
(a*b*c)^1/3
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var a:=ArrRandom(10,10,20); a.Println;
Writeln('Сумма кубов ',a.Select(x->x*x*x).Sum);
a.Transform(x->x-5); a.Println
end.
Тестовое решение
14 17 12 17 20 11 13 18 19 20
Сумма кубов 46517
9 12 7 12 15 6 8 13 14 15
2. "Школьный вариант"
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
var
a:array[1..10] of integer;
i,s:integer;
begin
Randomize;
s:=0;
for i:=1 to 10 do begin
a[i]:=Random(11)+10;
Write(a[i],' ');
s:=s+a[i]*sqr(a[i])
end;
Writeln;
Writeln('Сумма кубов ',s);
for i:=1 to 10 do begin
a[i]:=a[i]-5;
Write(a[i],' ')
end;
Writeln
end.