Программы на Питоне, решающие следующие задачи
Задача 1
С клавиатуры получено четырехзначное число. Вывести на экран сообщение, содержащее ответ на во Верно ли, что все цифры данного числа четные?".
Задача 2
Напишите программу, которая получает с клавиатуры число роз (целое число, не превышающее 100) и выводит это число со словом «роза», «роз» или «розы». Например, «33 роза», «6 роз», «26 розы».
Задача 3
Пользователь с клавиатуры вводит два двузначных числа. Вывести на экран сообщение, содержащее ответ на во Верно ли, что сумма квадратов цифр первого числа равна сумме квадратов цифр второго числа?".
1)
using System;
class Program {
static void Main() {
int num = 16;
bool isPow2 = true;
while (num > 1){
if (num % 2 == 0){
num /= 2;
} else {
isPow2 = false;
break;
}
}
if (isPow2)
Console.WriteLine("Является");
else
Console.WriteLine("Не является");
}
}
2)
using System;
class Program {
static Random rnd = new Random();
static void Main() {
int min = 1;
int max = 100;
int numOfAttempts = 8;
int x = rnd.Next(min, max);
bool isWin = false;
Console.WriteLine("Игра \"Больше-Меньше\"");
Console.Write("Задайте число попыток: ");
numOfAttempts = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Отгадайте число от {0} до {1}", min, max);
Console.WriteLine("Попытки: {0}\n", numOfAttempts);
int input;
do {
Console.Write("Введите число: ");
input = Convert.ToInt32(Console.ReadLine());
numOfAttempts--;
if (input > x)
Console.WriteLine("x < {0} [попытки: {1}]", input, numOfAttempts);
if (input < x)
Console.WriteLine("x > {0} [попытки: {1}]", input, numOfAttempts);
if (input == x){
isWin = true;
break;
}
} while (numOfAttempts > 0);
if (isWin){
Console.WriteLine("\nПобеда!");
} else {
Console.WriteLine("\nПроигрыш! Загаданное число: {0}", x);
}
}
}
ответ:Зачастую начинающих веб-мастеров мучает во почему одни сайты ранжируются выше и обходят конкурентов в поисковой выдаче. Причиной этого могут быть неправильно расставленные теги h1, h2…h6. Если эти теги расставлены неверно, без учета специфики ресурса, то поисковикам сложнее получить точную информацию о статьях и содержащихся в ней ключевых словах.
Теги h1—h6 позволяют выделить заголовки различных уровней. Они дают понять, какие части текста более точно отражают тему статьи и обеспечивают преимущества в ранжировании.
Грамотная расстановка тегов позволяет поисковым системам более точно отображать станицу по за в выдаче, что благоприятно сказывается на позиции ресурса:
Объяснение: