В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ЭлькаЭля
ЭлькаЭля
18.07.2020 19:03 •  Информатика

Программирование (Питон ,
Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. (Питон)
Числа вводятся через input, а также, для последовательности, нужен цикл for

Показать ответ
Ответ:
Софи1138
Софи1138
25.06.2021 06:32

Python

n=int(input('Введите количество чисел : '))

a=[0]*n

for i in range(n):

   a[i]=int(input('a['+str(i)+']='))

z=999999

for i in a:

   if z>i and i%2==0:

       z=i

if z!=999999:

   print('минимальное чётное число=', z)

else:

   print('Чётных чисел не найдено')

# 2 вариант с использованием sorted    

n=int(input('Введите количество чисел : '))

a=[0]*n

for i in range(n):

   a[i]=int(input('a['+str(i)+']='))

a=sorted(a)

for i in a:

   if i%2==0:

       print('минимальное чётное число=', i)

       break

   


Программирование (Питон , Напишите программу, которая в последовательности натуральных чисел опреде
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота