В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Yorfound
Yorfound
03.12.2022 11:00 •  Информатика

Придумать свою задачу и написать программу в Pascal для ее решения. Программа должна содержать ветвление (условный оператор) и цикл

Показать ответ
Ответ:
karinaklinaeva
karinaklinaeva
29.04.2021 08:37

30 лет назад весь мир заворожённо наблюдал рождение блокбастеров века – «Терминатор», «Звёздные войны», «Робокоп». Советские дети просто зачитывались повестями Кира Булычёва, а любимыми фильмами были «Гостья и будущего» и «Лиловый шар». Волна научной фантастики и роботомании захватила умы советской молодёжи. И посей день, роботы вызывают самый неподдельный интерес у молодого поколения.

На самом деле, история робототехники уходит своими корнями в глубокую древность. Аж за 350 лет до нашей эры был создан первый в истории механический голубь. Его создатель – древнегреческий математик Архит – заложил прочный фундамент для дальнейшего развития механики.

Вообщем, робототехника нам нужна, в наше время роботы нужны, то чего не можем сделать мы , сделают они - роботы.

Ребят почитайте до конца, в конце норм вообще!!! В конце , последнее предложение классное.
0,0(0 оценок)
Ответ:
Cesar123213
Cesar123213
31.03.2022 15:29

ИТМО пишете?

GNU C++

#include <iostream>

#include <vector>

using namespace std;

signed main() {

   int N,k=0;

   cin>>N;

   int a[N];

   vector<pair<int,int> >b;

   for(int i=0;i<N;i++)

   {

       cin>>a[i];

   }

   int c = 1;

   for(int i=1;i<N;i++)

   {

       if (a[i]==a[i-1])

       {

           c++;

       }

       else

       {

           b.push_back(make_pair(a[i-1],c));

           c=1,k++;

       }

   }

   b.push_back(make_pair(a[N-1],c));

   cout<<k<<endl;

   for(int i=0;i<b.size();i++)

   {

       cout<<b[i].first<<' '<<b[i].second<<endl;

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота