В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
fox3221
fox3221
13.05.2022 22:02 •  Информатика

При регулярных выражений: 1. написать программу, которая проверяет, является ли введенная с клавиатуры строка двоичным числом. 2. написать программу, которая проверяет, является ли введенная с клавиатуры строка дробным числом. 3. дана строка. написать программу, которая находит в строке и выводит на экран только двузначные числа.

Показать ответ
Ответ:
юсуф37
юсуф37
06.10.2020 06:28
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  if s<>s.MatchValue('[01]+') then Write('не ');
  Writeln('двоичное число')
end.

Пример
010101111011
двоичное число

begin
  var s:=ReadlnString;
  if s<>s.MatchValue('[\+-]?\d+.\d+') then Write('не ');
  Writeln('дробное число')
end.

Пример
12.54
дробное число

begin
  var s:=ReadlnString;
  s.Matches('\s([\+-]?\d{2})\s').Select(t->Trim(t.Value)).Println;
end.

Пример
123.3 15 -11.7 +21 23.2 51 9 182
15 +21 51
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота