В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kate050804
kate050804
13.02.2023 12:08 •  Информатика

Составить программу.
• Ввести целое трехзначное число N>0.
• Найти сумму цифр данного числа. Вывести на печать с пояснениями.
• Если сумма цифр ≥14, напечатать «да», иначе напечатать «нет».​

Показать ответ
Ответ:
spirt708ozrmv0
spirt708ozrmv0
06.02.2021 03:38
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Ответ:
YndoQ
YndoQ
27.05.2021 07:36
Термин «информатика» появился в 1959 году в научном журнале communications of the acm[2], в котором луи фейн (louis fein) ратовал за создание высшей школы в области информатики аналогичной гарвардской бизнес-школе, созданной в 1921 году[3][уточнить]. обосновывая такое название школы, луи фейн ссылался на науку , которая так же как и информатика имеет прикладной и междисциплинарный характер, при этом имеет признаки, характерные для научной дисциплины. усилия луи фейна, численного аналитика джордж форсайта и других увенчались успехом: университеты пошли на создание программ, связанных с информатикой, начиная с университета пердью в 1962[4]. несмотря на своё название (от . computer science — компьютерная наука), большая часть научных направлений, связанных с информатикой, не включает изучение самих компьютеров. вследствие этого были предложены несколько альтернативных названий[5]. некоторые факультеты крупных университетов предпочитают термин вычислительная наука (computing science), чтобы подчеркнуть разницу между терминами. датский учёный питер наур предложил термин даталогия (datalogy)[6], чтобы отразить тот факт, что научная дисциплина оперирует данными и занимается обработкой данных, хотя и не обязательно с применением компьютеров. первым научным учреждением, включившим в название этот термин, был департамент даталогии (datalogy) в университете копенгагена, основанного в 1969 году, где работал питер наур, ставший первым профессором в даталогии (datalogy). этот термин используется в основном в скандинавских странах. в европе же часто используются термины, производные от сокращённого перевода фраз «автоматическая информация» (automatic information) (к примеру informazione automatica по-итальянски) и «информатика и » (information and mathematics), например, informatique (франция), informatik (германия), informatica (италия, нидерланды), informática (испания, португалия), informatika (в славянских языках) или pliroforiki (πληροφορική, что означает информатика) — в греции. подобные слова также были приняты в великобритании, например, школа информатики в университете эдинбурга[7]. в , , французском и языках в 1960-х годах была тенденция к замене термина «документация» терминами, имеющими в своей основе слово «информация»[8]. термин нем. informatik ввёл специалист карл штейнбух в статье informatik: automatische informationsverarbeitung (информатика: автоматическая обработка информации) 1957 года[9]. французский термин «informatique» введён в 1962 году филиппом дрейфусом, который также предложил перевод на ряд других европейских языков. в языке производной от термина «документация» стала документалистика и получили распространение термины научная и научно-техническая информация. термины «информология» и «информатика» предложены в 1962 году членом-корреспондентом ан александром харкевичем. основы информатики как науки были изложены в книге «основы научной информации» 1965 года, которая была переиздана в 1968 году уже под названием «основы информатики»[10]. во франции термин официально вошёл в употребление в 1966 году[11]. в языке термин нем. informatik имел вначале двойственное значение. так, в фрг[8] и великобритании[1] он был в значении «computer science», то есть означал всё, что связано с применением эвм, а в гдр, как и в основном по европе, обозначал науку по французской и модели.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота